Back to overview
Degraded

SMS delivery problem to Rogers' customers

Aug 28 at 06:54am EDT
Affected services
SMS delivery

Resolved
Sep 05 at 04:58pm EDT

We haven't received any report of delivery problem to Rogers' customers since we have removed the email address from our validation message.

We are now considering this issue as resolved.

Updated
Sep 04 at 11:07am EDT

We haven't received any report of delivery problem to Rogers' customers since we have removed the email address from our validation message.

We continue to monitor the situation.

Updated
Sep 03 at 07:46pm EDT

Rogers has confirmed the blacklisting of our numbers based on the message content.

Based on their recommendation, we've removed the email address from our message and we think this will bypass their automated anti-spam blacklisting system.

Before the change, the message was
"Your eZsign validationcode is 1234. This message was sent by John Doe (john.doe@example.com)".

The new message is now:
"Your eZsign validationcode is 1234. This message was sent by John Doe".

We will continue to monitor the situation.

Updated
Sep 02 at 11:59am EDT

We continue to monitor SMS delivery and remove phone numbers from the pool as soon as Rogers blacklist them. We purchase and replace new numbers as needed.

We are now observing a 90-95% delivery rates.

We have also added a message explaining the situation and inviting users to retry if they do not receive the message. Since the SMS message is randomly sent from a pool of numbers, the retry should work in case the first message was not received.

We continue to monitor the situation.

Updated
Sep 01 at 07:36pm EDT

We have purchased a pool of multiple phone numbers and we are now sending messages to Rogers' customer using a random number from the pool in a round robin fashion.

We are now seeing higher SMS delivery rate to Rogers's customer.

We will monitor the pool of numbers and replace them if Rogers continue to blacklist them while we are working with them to make sure they do not blacklist our numbers.

Updated
Sep 01 at 10:17am EDT

We have started to receive new reports of messages not being delivered to Rogers's customer.

We have confirmed our new number seem to be blacklisted from Rogers' side even if Rogers is denying it.

Updated
Aug 30 at 02:36pm EDT

We had no apparent improvement while working with Rogers to fix the issue so we decided in the meantime to purchase a new phone number to bypass the apparent blacklisting Rogers' have put on our number.

We have received reports of messages starting to be delivered to Rogers' customers.

We will continue to monitor the situation

Updated
Aug 29 at 11:55am EDT

We have received an update from Rogers saying the problem is not on their side but our tests indicate Rogers seems to have blacklisted our number in some way. We are still investigating the root cause with Rogers

Updated
Aug 28 at 04:47pm EDT

We continue to receive reports of clients having issues with SMS delivery to Rogers' customers. In the meantime, we recommend you switch to voice validation instead of the SMS validation if you are a Rogers' customer

Updated
Aug 28 at 08:12am EDT

We were able to confirm the problem is affecting many Rogers' customers and have escalated the issue to Rogers

Created
Aug 28 at 06:54am EDT

We have received reports from clients not receiving SMS confirmation codes.

The problem seems to affect only Rogers' customers.

We are currently investigating the issue